Ubuntu 16.04 安裝 apache2.4 加上 php7.1

2017-05-02 Apache, php, Ubuntu

前一篇有安裝過 PHP7.0,順手將 PHP 7.1 的 Template 給開發者使用,順便記錄一下 PHP 7.1 的安裝流程

 

採用 Ubuntu 16.04 的 OS 環境,並且使用 Apache 2.4 加上 PHP7.1。

 

Ubuntu 16.04 安裝 apache2.4 + php 7.1

 

Step 1. 在 Ubuntu 16.04 中的 default 的 php 最高只有到 php7.0,如果要安裝 php7.1 要使用 ppa 來加入官方 repository。

 

Step 2. 用 apt 安裝基本 apache2 和 php7.1

 

Step 3. 設定 apache 2.4

 

Step 4. 印一個 phpinfo 出來

 

Step 5. 啟動 apache 2.4

 

和 php 7.0 一樣,會把 mpm mode 由 event 改為 prefork。

 

發表迴響

你的電子郵件位址並不會被公開。 必要欄位標記為 *

彙整

分類

open all | close all

License

訂閱 Mr. 沙先生 的文章

輸入你的 email 用於訂閱

%d 位部落客按了讚: